www.wfdy.net > python已成功安装sklEArn,但导入会提示错误,求解答

python已成功安装sklEArn,但导入会提示错误,求解答

这个是做什么的

先看你有没有安装sklearn这个模块,如果没装就安装一下,如果有装,你的是什么版本的python,如果是2.7就安装一下vc 2008运行库,如果是3.X就装一下VC 2012的运行库就可以了

用PYDEV开发的? 检查下sklearn 在不在pydev-interpreter里的library目录里,重启下eclipse. 声明下没用过sklearn,以上只是根据错误提示做的判断。

首先,检查一下有没有安装sklearn这个包,如果有,那么再检查有没有安装numpy,scipy。 如果都安装了还是报错,可以把C:\Python27\Lib\site-packages里面的这三个包删掉,然后去http://www.lfd.uci.edu/~gohlke/pythonlibs/#scikit-learn下载你...

1 首先需要安装Cython,网上下载后进行本地安装 python setup.py install 2 下载Sklearn包,进行本地安装(使用pip或easy_install总是出错,如can not import murmurhash3_32,最终本地安装成功) 3 安装后可用nosetests -v sklearn来进行测试

在Python中,出现'no module named sklean'的原因是,没有正确安装sklean包。可以使用pip包管理器来安装包,pip包管理器会自动安装包所依赖的包而无需额外手动安装,因此十分方便。使用pip包管理器安装包的方法如下: 在命令行中输入:pip insta...

在Python中,出现'no module named sklean'的原因是,没有正确安装sklean包。可以使用pip包管理器来安装包,pip包管理器会自动安装包所依赖的包而无需额外手动安装,因此十分方便。使用pip包管理器安装包的方法如下: 在命令行中输入: 1 pip in...

你是怎么安装包的,应该是你没有安装成功, sklearn包可以直接使用pip包管理器,在命令行输入: pip install scikit-learn numpy,scipy,matplotlib最简单的安装方式是到:http://www.lfd.uci.edu/~gohlke/pythonlibs/#numpy,下载,注意选择正确...

报错信息说明问题出在scipy包的sparse部分。 建议重新安装一下scipy,或者找一些例子测试一下scipy包的功能。

可以使用机器学习,使用很方便(相当于别人早已经把具体过程做好了,像公式、模板一样自己代入数据就可以得到结果) from sklearn.linear_model import LogisticRegression

网站地图

All rights reserved Powered by www.wfdy.net

copyright ©right 2010-2021。
www.wfdy.net内容来自网络,如有侵犯请联系客服。zhit325@qq.com